Учебник РНР
Назад Приложение B. Переход от PHP 3 к PHP 4 Вперёд

Конкурентный запуск PHP 3 и PHP 4

Новейшие ОС дают возможность отслеживать версии и область видимости. Это позволяет запускать PHP 3 и PHP 4 как конкурирующие модули на одном сервере Apache.

Известно, что это будет работать на следующих платформах:

  • Linux с последними binutils (протестированы binutils 2.9.1.0.25)

  • Solaris 2.5 или новее

  • FreeBSD (проверены 3.2, 4.0)

Сконфигурируйте PHP3 и PHP4 для использования APXS (--with-apxs) и необходимых расширений ссылок (--enable-versioning). В ином случае можно применить все инструкции стандартной инсталяции. Например:
$ ./configure \
  --with-apxs=/apache/bin/apxs \
  --enable-versioning \
  --with-mysql \
  --enable-track-vars


НазадОглавление Вперёд
Переход от PHP 3 к PHP 4 ВверхПеренос файлов конфигурации




HTML Site Map